TAMSII

Checkout Tools
  • last updated 3 hours ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
[TNSS-7652] - Refactor to prepare any signature logic changes
[TNSS-7884] (v.4.15.00.00) DB file changes for new branch.
    • ?
    /branches/b_4_15_00_00/Database/DBUnload/DB_RELEASE.dat
[TII-61734]-Creating Branch from the following tag v.4.14.00.00
TII-20182: Allow the new Customer and Product Certifications to be sent / received with TAMS/MS
TII-20182: Allow the new Customer and Product Certifications to be sent / received with TAMS/MS
Code looks good.

Code looks good.

[TAMSIIS-2247] Added a record to FileActivity so that calls to sp_consol_orders2 would be processed...
[TAMSIIS-2247] Added a record to FileActivity so that calls to sp_consol_orders2 would be processed...
Code review complete. Everything looks good to me.

Code review complete. Everything looks good to me.

[TAMSIIS-1512] Add Reason Codes 6-9 to ME - MIC Class Returns
[TAMSIIS-1512] Add Reason Codes 6-9 to ME - MIC Class Returns
[TAMSIIS-1512] Add Reason Codes 6-9 to ME - MIC Class Returns
[TAMSIIS-1512] Add Reason Codes 6-9 to ME - MIC Class Returns
[TII-21601] Made code changes to provide common framework for the full resync of any data feed.
[TII-21601] Made code changes to provide common framework for the full resync of any data feed.
add a log message here indicating that the synchronization is complete.

add a log message here indicating that the synchronization is complete.

This needs to be an else clause, right - you don't want to call saveChangeQueueRecords() if there are no parts in the list to save, right?

This needs to be an else clause, right - you don't want to call saveChangeQueueRecords() if there are no parts in the list to save, right?

[TII-21598] Made code changes to provide common framework for getting incremental data and sending it...
[TII-21598] Made code changes to provide common framework for getting incremental data and sending it...
If we're adding a bunch of empty functions, it's a potential architectural weakness. Is InventoryVerifier truly a Synchronizer? What happens if the InventoryVerifier doesn't extends AbstractSynchr...

If we're adding a bunch of empty functions, it's a potential architectural weakness.

Is InventoryVerifier truly a Synchronizer? What happens if the InventoryVerifier doesn't extends AbstractSynchronizer? What functionality of the AbstractSynchronizer, other than tableId is being used by InventoryVerifier? If the answer is "none" or "very little", then there's no need for InventoryVerifier to extend Synchronizer

This whole subsequence should move to the base class, or into some sort of utility class/helper, since all of the variants are going to need this.

This whole subsequence should move to the base class, or into some sort of utility class/helper, since all of the variants are going to need this.

another typo in the name

another typo in the name

typo in name

typo in name

[TII-21415] Made code changes to stop cart code going through a transaction management code in jboss5....
[TII-21415] Made code changes to stop cart code going through a transaction management code in jboss5....
What does 'isBreakout' mean? I assume it means "stop processing the handler logic." But that seems like a change in the status. In other words, the naming here is confusing. It seems like the rig...

What does 'isBreakout' mean? I assume it means "stop processing the handler logic."

But that seems like a change in the status. In other words, the naming here is confusing.

It seems like the right approach would be two exceptions, one that does not stop processing, and one that does.

if we return null, we should indicate with a warning level log message that we were not able to validate the request

if we return null, we should indicate with a warning level log message that we were not able to validate the request

You should include the method name on this log message

You should include the method name on this log message

You should include the method name on this log message, since we have two now

You should include the method name on this log message, since we have two now

Do we know for a fact that no one will call any other method on StoreProfile other than getLanguageCode() or getCountryCode()? Will this approach break when we try to move this code to Canada or M...

Do we know for a fact that no one will call any other method on StoreProfile other than getLanguageCode() or getCountryCode()?

Will this approach break when we try to move this code to Canada or Mexico?